rudel-0.3_pre20110721-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. NEED_EMACS=24
  5. inherit readme.gentoo-r1 elisp
  6. DESCRIPTION="Collaborative editing environment for GNU Emacs"
  7. HOMEPAGE="http://rudel.sourceforge.net/
  8. http://www.emacswiki.org/emacs/Rudel"
  9. # snapshot of bzr://rudel.bzr.sourceforge.net/bzrroot/rudel/trunk
  10. SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
  11. LICENSE="GPL-3+"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. S="${WORKDIR}/${PN}"
  15. ELISP_PATCHES="${P}-emacs25.patch"
  16. SITEFILE="60${PN}-gentoo.el"
  17. src_compile() {
  18. ${EMACS} ${EMACSFLAGS} -l rudel-compile.el || die
  19. }
  20. src_install() {
  21. local dir
  22. for dir in . adopted infinote jupiter obby socket telepathy tls \
  23. xmpp zeroconf
  24. do
  25. insinto "${SITELISP}/${PN}/${dir}"
  26. doins ${dir}/*.{el,elc}
  27. done
  28. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  29. insinto "${SITEETC}/${PN}"
  30. doins -r icons
  31. dodoc README INSTALL ChangeLog TODO doc/card.pdf
  32. DOC_CONTENTS="Connections to Gobby servers require the gnutls-cli program
  33. (net-libs/gnutls).
  34. \\n\\nThe Avahi daemon (net-dns/avahi) is required for automatic
  35. session discovery and advertising."
  36. readme.gentoo_create_doc
  37. }