zenirc-2.112-r1.ebuild 995 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit readme.gentoo elisp
  5. DESCRIPTION="A full-featured scriptable IRC client for the Emacs text editor"
  6. HOMEPAGE="http://www.zenirc.org/"
  7. SRC_URI="ftp://ftp.zenirc.org/pub/zenirc/${P}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. SITEFILE="50${PN}-gentoo.el"
  12. src_configure() {
  13. # econf won't work because of unknown options
  14. ./configure --prefix="${EPREFIX}/usr/" || die "configure failed"
  15. }
  16. src_compile() {
  17. default
  18. }
  19. src_install() {
  20. elisp-install ${PN} src/*.el src/*.elc
  21. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  22. doinfo doc/zenirc.info
  23. dodoc BUGS INSTALL NEWS README TODO
  24. cd doc
  25. docinto doc
  26. dodoc 666.conspiracy FAQ README-OLD ctcp.doc irc-operators \
  27. server-list tao-of-irc tour.of.irc undernet
  28. DOC_CONTENTS="Refer to the Info documentation and
  29. ${SITELISP}/${PN}/zenirc-example.el for customization hints."
  30. readme.gentoo_create_doc
  31. }