crossover-office-pro-bin-5.0.3.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit unpacker
  5. DESCRIPTION="simplified/streamlined version of wine with commercial support"
  6. HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
  7. SRC_URI="install-crossover-pro-${PV}.sh"
  8. LICENSE="CROSSOVER"
  9. SLOT="0"
  10. KEYWORDS="-* amd64 x86"
  11. IUSE="nas"
  12. RESTRICT="bindist fetch strip"
  13. RDEPEND="
  14. dev-util/desktop-file-utils
  15. sys-libs/glibc
  16. x11-libs/libXrandr[abi_x86_32(-)]
  17. x11-libs/libXi[abi_x86_32(-)]
  18. x11-libs/libXmu[abi_x86_32(-)]
  19. x11-libs/libXxf86dga[abi_x86_32(-)]
  20. x11-libs/libXxf86vm[abi_x86_32(-)]
  21. nas? ( media-libs/nas[abi_x86_32(-)] )
  22. "
  23. S=${WORKDIR}
  24. pkg_nofetch() {
  25. einfo "Please visit ${HOMEPAGE}"
  26. einfo "and place ${A} in ${DISTDIR}"
  27. }
  28. src_unpack() {
  29. unpack_makeself # needed due to .sh extension; #415013
  30. }
  31. src_install() {
  32. dodir /opt/cxoffice
  33. cp -r * "${D}"/opt/cxoffice || die "cp failed"
  34. rm -r "${D}"/opt/cxoffice/setup.{sh,data}
  35. insinto /opt/cxoffice/etc
  36. doins support/templates/cxoffice.conf
  37. }
  38. pkg_postinst() {
  39. elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
  40. elog "bottles and install Windows applications."
  41. }