crossover-office-pro-bin-9.0.1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit unpacker
  5. DESCRIPTION="simplified/streamlined version of wine with commercial support"
  6. HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
  7. SRC_URI="install-crossover-pro-${PV}.sh"
  8. LICENSE="CROSSOVER"
  9. SLOT="0"
  10. KEYWORDS="-* amd64 x86"
  11. IUSE="nas"
  12. RESTRICT="bindist fetch strip"
  13. RDEPEND="
  14. dev-util/desktop-file-utils
  15. sys-libs/glibc
  16. x11-libs/libXrandr[abi_x86_32(-)]
  17. x11-libs/libXi[abi_x86_32(-)]
  18. x11-libs/libXmu[abi_x86_32(-)]
  19. x11-libs/libXxf86dga[abi_x86_32(-)]
  20. x11-libs/libXxf86vm[abi_x86_32(-)]
  21. nas? ( media-libs/nas[abi_x86_32(-)] )
  22. "
  23. DEPEND=""
  24. S=${WORKDIR}
  25. pkg_nofetch() {
  26. einfo "Please visit ${HOMEPAGE}"
  27. einfo "and place ${A} in ${DISTDIR}"
  28. }
  29. src_unpack() {
  30. unpack_makeself # needed due to .sh extension; #415013
  31. }
  32. src_install() {
  33. dodir /opt/cxoffice
  34. cp -r * "${D}"/opt/cxoffice || die "cp failed"
  35. rm -r "${D}"/opt/cxoffice/setup.{sh,data}
  36. insinto /opt/cxoffice/etc
  37. doins share/crossover/data/cxoffice.conf
  38. }
  39. pkg_postinst() {
  40. elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
  41. elog "bottles and install Windows applications."
  42. }