crossover-office-pro-bin-9.1.0.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit unpacker
  5. DESCRIPTION="simplified/streamlined version of wine with commercial support"
  6. HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
  7. SRC_URI="install-crossover-pro-${PV}.sh"
  8. LICENSE="CROSSOVER"
  9. SLOT="0"
  10. KEYWORDS="-* amd64 x86"
  11. IUSE="nas"
  12. RESTRICT="bindist fetch strip"
  13. RDEPEND="
  14. dev-util/desktop-file-utils
  15. sys-libs/glibc
  16. x11-libs/libXrandr[abi_x86_32(-)]
  17. x11-libs/libXi[abi_x86_32(-)]
  18. x11-libs/libXmu[abi_x86_32(-)]
  19. x11-libs/libXxf86dga[abi_x86_32(-)]
  20. x11-libs/libXxf86vm[abi_x86_32(-)]
  21. || ( virtual/jpeg:62[abi_x86_32(-)] media-libs/jpeg:62[abi_x86_32(-)] )
  22. media-libs/libpng:1.2[abi_x86_32(-)]
  23. nas? ( media-libs/nas[abi_x86_32(-)] )
  24. "
  25. DEPEND=""
  26. S=${WORKDIR}
  27. pkg_nofetch() {
  28. einfo "Please visit ${HOMEPAGE}"
  29. einfo "and place ${A} in ${DISTDIR}"
  30. }
  31. src_unpack() {
  32. unpack_makeself # needed due to .sh extension; #415013
  33. }
  34. src_install() {
  35. dodir /opt/cxoffice
  36. cp -r * "${D}"/opt/cxoffice || die "cp failed"
  37. rm -r "${D}"/opt/cxoffice/setup.{sh,data}
  38. insinto /opt/cxoffice/etc
  39. doins share/crossover/data/cxoffice.conf
  40. }
  41. pkg_postinst() {
  42. elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
  43. elog "bottles and install Windows applications."
  44. }