ibus-qt-1.3.2.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit cmake-utils eutils multilib
  5. MY_P="${P}-Source"
  6. DESCRIPTION="Qt IBus library and Qt input method plugin"
  7. HOMEPAGE="https://github.com/ibus/ibus/wiki"
  8. SRC_URI="https://ibus.googlecode.com/files/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="doc"
  13. RDEPEND=">=app-i18n/ibus-1.3.7
  14. >=sys-apps/dbus-1.2
  15. x11-libs/libX11
  16. >=dev-qt/qtcore-4.5:4
  17. >=dev-qt/qtdbus-4.5:4"
  18. DEPEND="${RDEPEND}
  19. >=dev-libs/icu-4:=
  20. dev-util/cmake
  21. virtual/pkgconfig
  22. doc? ( app-doc/doxygen )"
  23. S="${WORKDIR}/${MY_P}"
  24. DOCS="AUTHORS README TODO"
  25. src_configure() {
  26. local mycmakeargs=( -DLIBDIR=$(get_libdir) -DDOCDIR=${EPREFIX}/usr/share/doc/${PF} all )
  27. cmake-utils_src_configure
  28. }
  29. src_prepare() {
  30. epatch "${FILESDIR}/${PN}-1.2.0.20091217-doc.patch"
  31. }
  32. src_compile() {
  33. cmake-utils_src_compile
  34. if use doc ; then
  35. cd "${CMAKE_BUILD_DIR}"
  36. emake docs || die
  37. fi
  38. }
  39. src_install() {
  40. if use doc ; then
  41. HTML_DOCS="${CMAKE_BUILD_DIR}/docs/html/*"
  42. fi
  43. cmake-utils_src_install
  44. }