im-ja-1.5-r3.ebuild 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GNOME2_LA_PUNT="yes"
  5. GCONF_DEBUG="no"
  6. inherit autotools gnome2 eutils multilib readme.gentoo
  7. DESCRIPTION="A Japanese input module for GTK2 and XIM"
  8. HOMEPAGE="http://im-ja.sourceforge.net/"
  9. SRC_URI="http://im-ja.sourceforge.net/${P}.tar.gz
  10. http://im-ja.sourceforge.net/old/${P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="amd64 ppc x86"
  14. IUSE="canna freewnn skk anthy"
  15. # --enable-debug causes build failure with gtk+-2.4
  16. #IUSE="${IUSE} debug"
  17. RDEPEND="
  18. >=dev-libs/glib-2.4:2
  19. >=dev-libs/atk-1.6
  20. >=x11-libs/gtk+-2.4:2
  21. >=x11-libs/pango-1.2.1
  22. >=gnome-base/gconf-2.4:2
  23. >=gnome-base/libglade-2.4:2.0
  24. >=gnome-base/libgnomeui-2.4
  25. freewnn? ( app-i18n/freewnn )
  26. canna? ( app-i18n/canna )
  27. skk? ( virtual/skkserv )
  28. anthy? ( app-i18n/anthy )
  29. "
  30. DEPEND="${RDEPEND}
  31. dev-lang/perl
  32. dev-util/intltool
  33. dev-perl/URI
  34. virtual/pkgconfig
  35. "
  36. DISABLE_AUTOFORMATTING="yes"
  37. DOC_CONTENTS="This version of im-ja comes with experimental XIM support.
  38. If you'd like to try it out, run im-ja-xim-server and set
  39. environment variable XMODIFIERS to @im=im-ja-xim-server
  40. e.g.)
  41. $ export XMODIFIERS=@im=im-ja-xim-server (sh)
  42. > setenv XMODIFIERS @im=im-ja-xim-server (csh)"
  43. src_prepare() {
  44. epatch "${FILESDIR}/${P}-gentoo.patch" \
  45. "${FILESDIR}"/${P}-pofiles.patch \
  46. "${FILESDIR}/${P}-underlinking.patch"
  47. sed -ie 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in || die
  48. eautoreconf
  49. gnome2_src_prepare
  50. }
  51. src_configure() {
  52. local myconf
  53. # You cannot use `use_enable ...` here. im-ja's configure script
  54. # doesn't distinguish --enable-canna from --disable-canna, so
  55. # --enable-canna stands for --disable-canna in the script ;-(
  56. use canna || myconf="$myconf --disable-canna"
  57. use freewnn || myconf="$myconf --disable-wnn"
  58. use anthy || myconf="$myconf --disable-anthy"
  59. use skk || myconf="$myconf --disable-skk"
  60. #use debug && myconf="$myconf --enable-debug"
  61. gnome2_src_configure \
  62. --disable-gnome \
  63. $myconf
  64. }
  65. src_install() {
  66. gnome2_src_install
  67. sed -e "s:@EPREFIX@:${EPREFIX}:" "${FILESDIR}/xinput-${PN}" > "${T}/${PN}.conf" || die
  68. insinto /etc/X11/xinit/xinput.d
  69. doins "${T}/${PN}.conf"
  70. readme.gentoo_create_doc
  71. }
  72. pkg_postinst() {
  73. gnome2_query_immodules_gtk2
  74. gnome2_pkg_postinst
  75. readme.gentoo_print_elog
  76. }
  77. pkg_postrm() {
  78. gnome2_query_immodules_gtk2
  79. gnome2_pkg_postrm
  80. }