countrycodes-1.0.5-r1.ebuild 779 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="An ISO 3166 country code finder"
  6. HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
  7. SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
  11. IUSE=""
  12. S="${WORKDIR}"/${P}/src
  13. src_prepare() {
  14. epatch "${FILESDIR}"/${PV}-Makefile.patch
  15. tc-export CC
  16. }
  17. src_install() {
  18. emake \
  19. prefix="${D}/usr" \
  20. mandir="${D}/usr/share/man/man1" install || die "make install failed"
  21. dosym iso3166 /usr/bin/countrycodes || die
  22. dosym iso3166.1 /usr/share/man/man1/countrycodes || die
  23. dodoc ../doc/{Changelog,README} || die
  24. prepman
  25. }