dailystrips-1.0.28-r2.ebuild 810 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="dailystrips automatically downloads your favorite online comics from the web"
  4. HOMEPAGE="http://dailystrips.sourceforge.net/"
  5. SRC_URI="mirror://sourceforge/dailystrips/${P}.tar.gz"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="alpha amd64 ppc x86"
  9. IUSE=""
  10. RDEPEND=">=dev-perl/libwww-perl-5.50
  11. dev-perl/DateTime
  12. dev-perl/TimeDate"
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. sed -i \
  17. -e "s:/usr/share/dailystrips/strips.def:/etc/strips.def:" \
  18. dailystrips \
  19. || die "sed dailystrips failed"
  20. }
  21. src_install() {
  22. dobin dailystrips dailystrips-clean dailystrips-update \
  23. || die "dobin failed"
  24. dodoc BUGS CHANGELOG CONTRIBUTORS README* TODO
  25. insinto /etc
  26. doins strips.def || die "doins failed"
  27. }