glastree-1.04.ebuild 635 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
  6. HOMEPAGE="http://www.igmus.org/code/"
  7. SRC_URI="http://www.igmus.org/files/${P}.tar.gz"
  8. DEPEND="dev-lang/perl
  9. dev-perl/Date-Calc"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ppc x86"
  12. IUSE=""
  13. LICENSE="public-domain"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${PN}-posix-make.patch
  16. }
  17. src_compile() { :; }
  18. src_install() {
  19. dodir /usr/share/man/man1
  20. emake INSTROOT="${D}"/usr INSTMAN=share/man install
  21. dodoc README CHANGES THANKS TODO
  22. }