gnote-3.22.1.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit gnome2 readme.gentoo-r1
  6. DESCRIPTION="Desktop note-taking application"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
  8. LICENSE="GPL-3+ FDL-1.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug"
  12. # Automagic glib-2.32 dep
  13. COMMON_DEPEND="
  14. >=app-crypt/libsecret-0.8
  15. >=app-text/gtkspell-3.0:3
  16. >=dev-cpp/glibmm-2.32:2
  17. >=dev-cpp/gtkmm-3.18:3.0
  18. >=dev-libs/boost-1.34:=
  19. >=dev-libs/glib-2.32:2[dbus]
  20. >=dev-libs/libxml2-2:2
  21. dev-libs/libxslt
  22. >=sys-apps/util-linux-2.16:=
  23. >=x11-libs/gtk+-3.20:3
  24. "
  25. RDEPEND="${COMMON_DEPEND}
  26. gnome-base/gsettings-desktop-schemas
  27. "
  28. DEPEND="${DEPEND}
  29. app-text/docbook-xml-dtd:4.1.2
  30. >=dev-util/intltool-0.35.0
  31. dev-util/itstool
  32. virtual/pkgconfig
  33. "
  34. src_prepare() {
  35. # Do not alter CFLAGS
  36. sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
  37. gnome2_src_prepare
  38. if has_version net-fs/wdfs; then
  39. DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
  40. synchronize notes."
  41. else
  42. DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
  43. If you want to use that functionality just emerge net-fs/wdfs.
  44. Gnote will automatically detect that you did and let you use it."
  45. fi
  46. }
  47. src_configure() {
  48. gnome2_src_configure \
  49. --disable-static \
  50. $(use_enable debug)
  51. }
  52. src_install() {
  53. gnome2_src_install
  54. readme.gentoo_create_doc
  55. }
  56. pkg_postinst() {
  57. gnome2_pkg_postinst
  58. readme.gentoo_print_elog
  59. }