hello-2.8.ebuild 611 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. DESCRIPTION="GNU \"Hello, world\" application"
  5. HOMEPAGE="https://www.gnu.org/software/hello/"
  6. SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
  7. LICENSE="FDL-1.3 GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  10. IUSE="nls"
  11. DOCS=(AUTHORS ChangeLog ChangeLog.O NEWS README THANKS TODO contrib/evolution.txt)
  12. src_configure() {
  13. econf $(use_enable nls)
  14. }
  15. src_install() {
  16. default
  17. for x in contrib man doc po tests src; do
  18. newdoc $x/ChangeLog ChangeLog.$x || die "newdoc failed"
  19. done
  20. }