bibutils-4.12.ebuild 1005 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit toolchain-funcs
  5. MY_P="${PN}_${PV}"
  6. DESCRIPTION="Interconverts between various bibliography formats using common XML intermediate"
  7. HOMEPAGE="http://www.scripps.edu/~cdputnam/software/bibutils/"
  8. SRC_URI="http://www.scripps.edu/~cdputnam/software/bibutils/${MY_P}_src.tgz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE=""
  13. S=${WORKDIR}/${MY_P}
  14. src_prepare() {
  15. # The custom configure script sucks, so we'll just do its
  16. # job ourselves
  17. rm -f Makefile configure || die "Failed to purge old Makefile"
  18. sed \
  19. -e "s:REPLACE_CC:CC=\"$(tc-getCC) ${CFLAGS}\":g" \
  20. -e "s:REPLACE_RANLIB:RANLIB=\"$(tc-getRANLIB)\":g" \
  21. -e "s:REPLACE_INSTALLDIR:\"${D}/usr/bin\":g" \
  22. -e 's:REPLACE_POSTFIX::g' \
  23. -e 's:make:$(MAKE):g' \
  24. Makefile_start > Makefile \
  25. || die "Failed to set up Makefile"
  26. }
  27. src_install() {
  28. dodir /usr/bin
  29. emake install || die
  30. dodoc ChangeLog || die
  31. }