htmlinc-1.0_beta1.ebuild 520 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="HTML Include System by Ulli Meybohm"
  5. HOMEPAGE="http://www.meybohm.de/"
  6. SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~ppc sparc x86"
  10. IUSE=""
  11. DEPEND=""
  12. S=${WORKDIR}/htmlinc
  13. src_unpack() {
  14. unpack ${A}
  15. epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
  16. }
  17. src_compile() {
  18. emake CFLAGS="${CXXFLAGS} -Wall" || die
  19. }
  20. src_install() {
  21. dobin htmlinc
  22. }