libgepub-0.4.ebuild 681 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="GObject based library for handling and rendering epub documents"
  6. HOMEPAGE="https://git.gnome.org/browse/libgepub"
  7. LICENSE="LGPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE="+introspection"
  11. RDEPEND="
  12. app-arch/libarchive
  13. dev-libs/glib:2
  14. dev-libs/libxml2
  15. net-libs/libsoup:2.4
  16. net-libs/webkit-gtk:4
  17. x11-libs/gtk+:3
  18. introspection? ( >=dev-libs/gobject-introspection-1.30:= )
  19. "
  20. DEPEND="${RDEPEND}
  21. gnome-base/gnome-common
  22. virtual/pkgconfig
  23. "
  24. src_configure() {
  25. gnome2_src_configure \
  26. --disable-static \
  27. $(use_enable introspection)
  28. }