psutils-1.17-r2.ebuild 1002 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=3
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="PostScript Utilities"
  6. HOMEPAGE="http://web.archive.org/web/20110722005140/http://www.tardis.ed.ac.uk/~ajcd/psutils/"
  7. SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.dfsg.orig.tar.gz"
  8. LICENSE="psutils"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND="${RDEPEND}
  14. dev-lang/perl"
  15. S="${WORKDIR}/${P}.orig"
  16. src_prepare() {
  17. epatch "${FILESDIR}/${P}-ldflags.patch"
  18. epatch "${FILESDIR}/${P}-no-fixmacps.patch"
  19. sed \
  20. -e "s:/usr/local:\$(DESTDIR)${EPREFIX}/usr:" \
  21. "${S}/Makefile.unix" > "${S}/Makefile"
  22. }
  23. src_compile() {
  24. emake CC="$(tc-getCC)" || die
  25. }
  26. src_install () {
  27. dodir /usr/{bin,share/man}
  28. emake DESTDIR="${D}" install || die
  29. dodoc README
  30. }