queequeg-0.91-r2.ebuild 1002 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="A checker for English grammar, for people who are not native English"
  7. HOMEPAGE="http://queequeg.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. DEPEND="${PYTHON_DEPS}
  15. app-dicts/wordnet"
  16. RDEPEND="${DEPEND}"
  17. src_compile() {
  18. local dictdir=/usr/dict
  19. if has_version ">=app-dicts/wordnet-2.0"; then
  20. dictdir=/usr/share/wordnet/dict
  21. fi
  22. emake dict WORDNETDICT=${dictdir}
  23. python_fix_shebang qq
  24. }
  25. src_install() {
  26. local prefix=/usr/lib/queequeg
  27. python_moduleinto "${prefix}"
  28. python_domodule *.py
  29. insinto "${prefix}"
  30. [[ -f "dict.txt" ]] && doins dict.txt || doins dict.cdb
  31. exeinto "${prefix}"
  32. doexe qq
  33. dodir /usr/bin
  34. dosym ../lib/queequeg/qq /usr/bin/qq
  35. dodoc README TODO
  36. dodoc htdocs/*
  37. }