refbase-0.9.5.ebuild 904 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit depend.apache webapp
  5. DESCRIPTION="Web-based solution for managing scientific literature, references and citations"
  6. HOMEPAGE="http://www.refbase.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. KEYWORDS="~x86 ~amd64"
  10. IUSE=""
  11. DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
  12. dev-lang/php[mysql,session]
  13. app-admin/webapp-config
  14. app-text/bibutils"
  15. RDEPEND="${DEPEND}"
  16. need_apache
  17. pkg_setup() {
  18. webapp_pkg_setup
  19. }
  20. src_install () {
  21. webapp_src_preinst
  22. DOCS="AUTHORS BUGS ChangeLog NEWS README TODO UPDATE"
  23. dodoc ${DOCS}
  24. # Don't install docs to webroot
  25. rm -f ${DOCS} COPYING INSTALL
  26. cp -R * "${D}"${MY_HTDOCSDIR}
  27. webapp_configfile ${MY_HTDOCSDIR}/initialize
  28. webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
  29. webapp_src_install
  30. }