tuxcards-2.2.1-r1.ebuild 599 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils qmake-utils
  5. DESCRIPTION="A hierarchical notebook"
  6. HOMEPAGE="http://www.tuxcards.de/"
  7. SRC_URI="http://www.tuxcards.de/src/${P}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE=""
  12. DEPEND="dev-qt/qtgui:4"
  13. RDEPEND="${DEPEND}"
  14. S=${WORKDIR}/${PN}
  15. src_configure() {
  16. eqmake4 tuxcards.pro
  17. }
  18. src_install() {
  19. dobin ${PN}
  20. newicon src/icons/lo32-app-tuxcards.png ${PN}.png
  21. make_desktop_entry ${PN} TuxCards ${PN} "Qt;Utility"
  22. dodoc AUTHORS README
  23. }