tuxcards-2.2.1.ebuild 562 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=3
  4. inherit eutils qt4-r2
  5. DESCRIPTION="A hierarchical notebook"
  6. HOMEPAGE="http://www.tuxcards.de/"
  7. SRC_URI="http://www.tuxcards.de/src/${P}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="dev-qt/qtgui:4"
  13. RDEPEND="${DEPEND}"
  14. S=${WORKDIR}/${PN}
  15. src_install() {
  16. dobin ${PN} || die
  17. newicon src/icons/lo32-app-tuxcards.png ${PN}.png
  18. make_desktop_entry ${PN} TuxCards ${PN} "Qt;Utility"
  19. dodoc AUTHORS README || die
  20. }