xdvipdfmx-0.7.8_p20120701.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. DESCRIPTION="Extended dvipdfmx for use with XeTeX and other unicode TeXs"
  5. HOMEPAGE="http://scripts.sil.org/svn-view/xdvipdfmx/
  6. http://tug.org/texlive/"
  7. SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
  11. IUSE="doc"
  12. RDEPEND="!<app-text/texlive-core-2010
  13. dev-libs/kpathsea
  14. sys-libs/zlib
  15. media-libs/freetype:2
  16. media-libs/fontconfig
  17. >=media-libs/libpng-1.2.43-r2:0
  18. app-text/libpaper"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. # for dvipdfmx.cfg
  22. RDEPEND="${RDEPEND}
  23. app-text/dvipdfmx"
  24. S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
  25. src_configure() {
  26. # don't do OSX stuff as it breaks on using long gone freetype funcs
  27. export kpse_cv_have_ApplicationServices=no
  28. econf \
  29. --with-system-kpathsea \
  30. --with-system-zlib \
  31. --with-system-libpng \
  32. --with-system-freetype2
  33. }
  34. src_install() {
  35. emake DESTDIR="${D}" install
  36. dodoc README TODO BUGS AUTHORS ChangeLog ChangeLog.TL
  37. if use doc ; then
  38. insinto /usr/share/doc/${PF}
  39. doins -r doc
  40. fi
  41. }