xdvipdfmx-0.7.9_p20130530.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. DESCRIPTION="Extended dvipdfmx for use with XeTeX and other unicode TeXs"
  5. HOMEPAGE="http://scripts.sil.org/svn-view/xdvipdfmx/
  6. http://tug.org/texlive/"
  7. SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
  11. IUSE=""
  12. RDEPEND="!<app-text/texlive-core-2010
  13. dev-libs/kpathsea
  14. sys-libs/zlib
  15. media-libs/freetype:2
  16. >=media-libs/libpng-1.2.43-r2:0=
  17. app-text/libpaper"
  18. DEPEND="${RDEPEND}
  19. virtual/pkgconfig"
  20. # for dvipdfmx.cfg
  21. RDEPEND="${RDEPEND}
  22. app-text/dvipdfmx"
  23. S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
  24. src_configure() {
  25. # don't do OSX stuff as it breaks on using long gone freetype funcs
  26. export kpse_cv_have_ApplicationServices=no
  27. econf \
  28. --with-system-kpathsea \
  29. --with-system-zlib \
  30. --with-system-libpng \
  31. --with-system-freetype2
  32. }
  33. src_install() {
  34. emake DESTDIR="${D}" install
  35. dodoc README AUTHORS ChangeLog
  36. }