zathura-pdf-poppler-9999.ebuild 906 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. [[ ${PV} == 9999* ]] && inherit git-2
  6. DESCRIPTION="PDF plug-in for zathura"
  7. HOMEPAGE="http://pwmt.org/projects/zathura/"
  8. if ! [[ ${PV} == 9999* ]]; then
  9. SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
  10. fi
  11. EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
  12. EGIT_BRANCH="develop"
  13. LICENSE="ZLIB"
  14. SLOT="0"
  15. if ! [[ ${PV} == 9999* ]]; then
  16. KEYWORDS="~amd64 ~arm ~x86"
  17. else
  18. KEYWORDS=""
  19. fi
  20. IUSE=""
  21. RDEPEND="app-text/poppler:=[cairo]
  22. >=app-text/zathura-0.2.7
  23. x11-libs/cairo:="
  24. DEPEND="${RDEPEND}
  25. virtual/pkgconfig"
  26. pkg_setup() {
  27. myzathuraconf=(
  28. CC="$(tc-getCC)"
  29. LD="$(tc-getLD)"
  30. VERBOSE=1
  31. DESTDIR="${D}"
  32. )
  33. }
  34. src_compile() {
  35. emake "${myzathuraconf[@]}"
  36. }
  37. src_install() {
  38. emake "${myzathuraconf[@]}" install
  39. dodoc AUTHORS
  40. }