airline-0.8.ebuild 750 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit vim-plugin
  5. if [[ ${PV} != 9999* ]] ; then
  6. MY_PN=vim-${PN}
  7. MY_P=${MY_PN}-${PV}
  8. SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. KEYWORDS="amd64 x86"
  10. S="${WORKDIR}/${MY_P}"
  11. else
  12. inherit git-r3
  13. EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
  14. fi
  15. DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
  16. HOMEPAGE="https://github.com/vim-airline/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
  17. LICENSE="MIT"
  18. VIM_PLUGIN_HELPFILES="${PN}.txt"
  19. src_prepare() {
  20. # remove unwanted files
  21. rm -r t Gemfile Rakefile LICENSE README* || die
  22. }