pyclewn-2.1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. inherit eutils vim-plugin distutils-r1
  6. SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
  7. DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
  8. HOMEPAGE="http://pyclewn.sourceforge.net/"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86"
  11. CDEPEND="|| (
  12. >=app-editors/vim-7.3[${PYTHON_USEDEP}]
  13. >=app-editors/gvim-7.3[netbeans,${PYTHON_USEDEP}]
  14. )"
  15. DEPEND="${CDEPEND}
  16. app-arch/vimball
  17. "
  18. RDEPEND="${DEPEND}
  19. $(python_gen_cond_dep \
  20. 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
  21. "
  22. SLOT="0"
  23. #Completely broken (runs vim), disable for now
  24. #python_test() {
  25. # esetup.py test
  26. #}
  27. python_install_all() {
  28. distutils-r1_python_install_all
  29. vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
  30. }
  31. pkg_postinst() {
  32. vim-plugin_pkg_postinst
  33. optfeature "C/C++ debugging" sys-devel/gdb
  34. optfeature "Python debugging" dev-python/pdb-clone
  35. }