pg_activity-1.2.0.ebuild 623 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
  7. HOMEPAGE="https://github.com/julmon/pg_activity/"
  8. SRC_URI="https://github.com/julmon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. KEYWORDS="~amd64 ~x86"
  10. SLOT="0"
  11. LICENSE="POSTGRESQL"
  12. DEPEND=""
  13. RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
  14. dev-python/setuptools[${PYTHON_USEDEP}]
  15. dev-python/psycopg:2[${PYTHON_USEDEP}]"
  16. src_install() {
  17. distutils-r1_src_install
  18. doman docs/man/${PN}.1
  19. }