soci-3.2.3.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. KEYWORDS="~amd64 ~x86"
  6. DESCRIPTION="Makes the illusion of embedding SQL queries in the regular C++ code"
  7. HOMEPAGE="http://soci.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
  9. LICENSE="Boost-1.0"
  10. SLOT="0"
  11. IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"
  12. DEPEND="boost? ( dev-libs/boost )
  13. firebird? ( dev-db/firebird )
  14. mysql? ( virtual/mysql )
  15. odbc? ( dev-db/unixODBC )
  16. oracle? ( dev-db/oracle-instantclient-basic )
  17. postgres? ( dev-db/postgresql:= )
  18. sqlite? ( dev-db/sqlite:3 )
  19. "
  20. RDEPEND=${DEPEND}
  21. src_configure() {
  22. local mycmakeargs="$(cmake-utils_use_with boost )
  23. $(cmake-utils_use empty SOCI_EMPTY)
  24. $(cmake-utils_use_with firebird FIREBIRD)
  25. $(cmake-utils_use_with mysql MYSQL)
  26. $(cmake-utils_use_with odbc ODBC)
  27. $(cmake-utils_use_with oracle ORACLE)
  28. $(cmake-utils_use_with postgres POSTGRESQL)
  29. $(cmake-utils_use_with sqlite SQLITE3)
  30. -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 support
  31. cmake-utils_src_configure
  32. }
  33. src_install() {
  34. cmake-utils_src_install
  35. dodoc AUTHORS CHANGES
  36. if use doc; then
  37. dohtml -r doc/*
  38. fi
  39. }