atk-2.22.0.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 multilib-minimal
  5. DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
  6. HOMEPAGE="https://wiki.gnome.org/Accessibility"
  7. LICENSE="LGPL-2+"
  8. SLOT="0"
  9. KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
  10. IUSE="+introspection nls test"
  11. RDEPEND="
  12. >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
  13. introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
  14. "
  15. DEPEND="${RDEPEND}
  16. >=dev-lang/perl-5
  17. dev-util/gtk-doc-am
  18. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  19. nls? ( >=sys-devel/gettext-0.19.2 )
  20. "
  21. src_prepare() {
  22. gnome2_src_prepare
  23. if ! use test; then
  24. # don't waste time building tests (bug #226353)
  25. sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
  26. || die "sed failed"
  27. fi
  28. # Building out of sources fails, https://bugzilla.gnome.org/show_bug.cgi?id=752507
  29. multilib_copy_sources
  30. }
  31. multilib_src_configure() {
  32. # ECONF_SOURCE=${S} \
  33. gnome2_src_configure \
  34. $(multilib_native_use_enable introspection)
  35. # work-around gtk-doc out-of-source brokedness
  36. # if multilib_is_native_abi; then
  37. # ln -s "${S}"/docs/html docs/html || die
  38. # fi
  39. }
  40. multilib_src_install() {
  41. gnome2_src_install
  42. }