jemalloc-2.2.5-r1.ebuild 908 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils
  5. DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
  6. HOMEPAGE="http://www.canonware.com/jemalloc/"
  7. SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~mips ppc ppc64 x86"
  11. IUSE="debug static-libs stats"
  12. DEPEND=""
  13. RDEPEND=""
  14. src_prepare() {
  15. epatch \
  16. "${FILESDIR}/${PN}-strip-optimization.patch" \
  17. "${FILESDIR}/${PN}-2.2.1-no-pprof.patch" \
  18. "${FILESDIR}/${PN}-2.2.5_fix_html_install.patch"
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf \
  23. --with-jemalloc-prefix=j \
  24. $(use_enable debug) \
  25. $(use_enable stats)
  26. }
  27. src_install() {
  28. emake DESTDIR="${ED}" install || die
  29. dodoc ChangeLog README
  30. dohtml doc/jemalloc.html
  31. use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
  32. }