json-glib-1.2.8.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 multilib-minimal
  5. DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
  6. HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
  7. LICENSE="LGPL-2.1+"
  8. SLOT="0"
  9. KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-fbsd ~x86-fbsd"
  10. IUSE="debug +introspection"
  11. RDEPEND="
  12. >=dev-libs/glib-2.37.6:2[${MULTILIB_USEDEP}]
  13. introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
  14. "
  15. DEPEND="${RDEPEND}
  16. ~app-text/docbook-xml-dtd-4.1.2
  17. app-text/docbook-xsl-stylesheets
  18. dev-libs/libxslt
  19. >=dev-util/gtk-doc-am-1.20
  20. >=sys-devel/gettext-0.18
  21. virtual/pkgconfig[${MULTILIB_USEDEP}]
  22. "
  23. src_prepare() {
  24. # Do not touch CFLAGS with --enable-debug=yes
  25. sed -e 's/CFLAGS -g/CFLAGS/' -i "${S}"/configure || die
  26. gnome2_src_prepare
  27. }
  28. multilib_src_configure() {
  29. # Coverage support is useless, and causes runtime problems
  30. ECONF_SOURCE=${S} \
  31. gnome2_src_configure \
  32. --enable-man \
  33. --disable-gcov \
  34. $(usex debug --enable-debug=yes --enable-debug=minimum) \
  35. $(multilib_native_use_enable introspection) \
  36. --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
  37. if multilib_is_native_abi; then
  38. ln -s "${S}"/doc/html doc/html || die
  39. fi
  40. }
  41. multilib_src_compile() {
  42. gnome2_src_compile
  43. }
  44. multilib_src_install() {
  45. gnome2_src_install
  46. }