libclc-0.2.0_pre20170118.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. EGIT_REPO_URI="http://llvm.org/git/${PN}.git
  6. https://github.com/llvm-mirror/${PN}.git"
  7. EGIT_COMMIT="2ec7d80d5e1c96fb85c694cc6ac0a78faf01a614"
  8. if [[ ${PV} = 9999* ]]; then
  9. GIT_ECLASS="git-r3"
  10. EXPERIMENTAL="true"
  11. else
  12. GIT_ECLASS="vcs-snapshot"
  13. fi
  14. inherit python-any-r1 toolchain-funcs ${GIT_ECLASS}
  15. DESCRIPTION="OpenCL C library"
  16. HOMEPAGE="http://libclc.llvm.org/"
  17. if [[ ${PV} = 9999* ]]; then
  18. SRC_URI="${SRC_PATCHES}"
  19. else
  20. SRC_URI="https://github.com/llvm-mirror/libclc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
  21. ${SRC_PATCHES}"
  22. fi
  23. LICENSE="|| ( MIT BSD )"
  24. SLOT="0"
  25. KEYWORDS="~amd64 ~x86"
  26. IUSE=""
  27. RDEPEND="
  28. >=sys-devel/clang-4
  29. >=sys-devel/llvm-4"
  30. DEPEND="${RDEPEND}
  31. ${PYTHON_DEPS}"
  32. src_configure() {
  33. ./configure.py \
  34. --with-cxx-compiler="$(tc-getCXX)" \
  35. --with-llvm-config="$(type -P llvm-config)" \
  36. --prefix="${EPREFIX}/usr" || die
  37. }
  38. src_compile() {
  39. emake VERBOSE=1
  40. }