libebml-1.3.4.ebuild 825 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Extensible binary format library (kinda like XML)"
  6. HOMEPAGE="http://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
  7. SRC_URI="http://dl.matroska.org/downloads/${PN}/${P}.tar.bz2"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0/4" # subslot = soname major version
  10. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
  11. IUSE="debug static-libs"
  12. src_prepare() {
  13. default
  14. sed -i '/^AM_CXXFLAGS += -g/d' Makefile.am || die
  15. eautoreconf
  16. }
  17. src_configure() {
  18. local myeconfargs=(
  19. $(use_enable debug)
  20. $(use_enable static-libs static)
  21. )
  22. econf "${myeconfargs[@]}"
  23. }
  24. src_install() {
  25. default
  26. find "${ED}" -name '*.la' -delete
  27. }