libezV24-0.1.1.ebuild 842 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils multilib toolchain-funcs
  4. DESCRIPTION="library that provides an easy API to Linux serial ports"
  5. HOMEPAGE="http://ezv24.sourceforge.net"
  6. SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 ppc sparc x86"
  10. IUSE=""
  11. RDEPEND=""
  12. DEPEND=""
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/${P}-build.patch
  17. epatch "${FILESDIR}"/${P}-test.patch
  18. sed -i -e 's:__LINUX__:__linux__:' *.c *.h
  19. }
  20. src_compile() {
  21. tc-export AR CC RANLIB
  22. emake || die "emake failed."
  23. }
  24. src_install() {
  25. export NO_LDCONFIG="stupid"
  26. emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
  27. install || die "emake install failed."
  28. dodoc AUTHORS BUGS ChangeLog HISTORY README
  29. dohtml api-html/*
  30. }