libgpg-error-1.26.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit libtool ltprune multilib-minimal toolchain-funcs
  5. DESCRIPTION="Contains error handling functions used by GnuPG software"
  6. HOMEPAGE="http://www.gnupg.org/related_software/libgpg-error"
  7. SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2 LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="common-lisp nls static-libs"
  12. RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
  13. abi_x86_32? (
  14. !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
  15. !<=app-emulation/emul-linux-x86-baselibs-20131008-r12
  16. )"
  17. DEPEND="${RDEPEND}
  18. nls? ( sys-devel/gettext )"
  19. MULTILIB_CHOST_TOOLS=(
  20. /usr/bin/gpg-error-config
  21. )
  22. MULTILIB_WRAPPED_HEADERS=(
  23. /usr/include/gpg-error.h
  24. )
  25. src_prepare() {
  26. default
  27. elibtoolize
  28. }
  29. multilib_src_configure() {
  30. ECONF_SOURCE="${S}" econf \
  31. CC_FOR_BUILD=$(tc-getBUILD_CC) \
  32. --enable-threads \
  33. $(use_enable nls) \
  34. $(use_enable static-libs static) \
  35. $(use_enable common-lisp languages) \
  36. $(multilib_is_native_abi || echo --disable-languages)
  37. }
  38. multilib_src_install_all() {
  39. einstalldocs
  40. prune_libtool_files --all
  41. }