libmongo-client-0.1.8.ebuild 743 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit autotools
  5. DESCRIPTION="The alternative C driver for MongoDB"
  6. HOMEPAGE="https://github.com/algernon/libmongo-client"
  7. SRC_URI="https://github.com/algernon/${PN}/archive/${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0/0.5.0"
  10. KEYWORDS="~amd64 ~arm ~hppa ~x86"
  11. IUSE="doc"
  12. DEPEND="${RDEPEND}
  13. doc? ( app-doc/doxygen )
  14. virtual/pkgconfig"
  15. RDEPEND="dev-libs/glib"
  16. S="${WORKDIR}/${PN}-${P}"
  17. src_prepare() {
  18. default
  19. eautoreconf
  20. }
  21. src_compile() {
  22. default
  23. use doc && emake DESTDIR="${D%/}" doxygen
  24. }
  25. src_install() {
  26. use doc && local HTML_DOCS=( docs/html/. )
  27. default
  28. find "${ED}"usr/lib* -name '*.la' -delete || die
  29. }