libmowgli-2.0.0-r1.ebuild 796 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
  5. HOMEPAGE="http://www.atheme.org/project/mowgli"
  6. SRC_URI="http://atheme.org/downloads/${P}.tar.gz"
  7. IUSE="libressl ssl"
  8. LICENSE="BSD-2"
  9. SLOT="2"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. RDEPEND="ssl? (
  12. !libressl? ( dev-libs/openssl:0= )
  13. libressl? ( dev-libs/libressl:0= )
  14. )"
  15. DEPEND="${RDEPEND}"
  16. DOCS="AUTHORS README doc/BOOST doc/design-concepts.txt"
  17. src_configure() {
  18. # disabling SSL is "broken" in 2.0.0 so we have to use this hack till 2.0.1
  19. use !ssl && myconf="--with-openssl=/dev/null"
  20. econf ${myconf}
  21. }