libzeitgeist-0.3.18.ebuild 1004 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. AUTOTOOLS_AUTORECONF=true
  5. inherit autotools-utils eutils versionator
  6. MY_PV=$(get_version_component_range 1-2)
  7. DESCRIPTION="Client library to interact with zeitgeist"
  8. HOMEPAGE="https://launchpad.net/libzeitgeist/"
  9. SRC_URI="https://launchpad.net/libzeitgeist/${MY_PV}/${PV}/+download/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  13. IUSE="static-libs"
  14. CDEPEND="dev-libs/glib:2"
  15. RDEPEND="${CDEPEND}
  16. gnome-extra/zeitgeist"
  17. DEPEND="${CDEPEND}
  18. dev-util/gtk-doc
  19. virtual/pkgconfig"
  20. src_prepare() {
  21. sed \
  22. -e "s:doc/libzeitgeist:doc/${PF}:" \
  23. -i Makefile.am || die
  24. # FIXME: This is the unique test failing
  25. sed \
  26. -e '/TEST_PROGS += test-log/d' \
  27. -i tests/Makefile.am || die
  28. sed \
  29. -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
  30. -e 's:AM_PROG_CC_STDC:AC_PROG_CC:g' \
  31. -i configure.ac || die
  32. autotools-utils_src_prepare
  33. }