pcc-libs-9999.ebuild 677 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils versionator
  5. DESCRIPTION="pcc compiler support libs"
  6. HOMEPAGE="http://pcc.ludd.ltu.se"
  7. if [[ ${PV} = 9999 ]]; then
  8. inherit cvs
  9. ECVS_SERVER="pcc.ludd.ltu.se:/cvsroot"
  10. ECVS_MODULE="${PN}"
  11. S="${WORKDIR}/${PN}"
  12. KEYWORDS=""
  13. else
  14. SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
  15. KEYWORDS="~x86 ~amd64 ~amd64-fbsd"
  16. fi
  17. LICENSE="BSD"
  18. SLOT="0"
  19. IUSE=""
  20. DEPEND=""
  21. RDEPEND="${DEPEND}"
  22. src_compile() {
  23. # not parallel-safe yet
  24. emake -j1 || die "emake failed"
  25. }
  26. src_install() {
  27. emake DESTDIR="${D}" install || die "emake install failed"
  28. }