pugixml-1.7.ebuild 580 B

12345678910111213141516171819202122
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
  6. HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
  7. SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. S=${WORKDIR}/${P}/scripts
  12. src_configure() {
  13. local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
  14. cmake-utils_src_configure
  15. }