serd-0.20.0.ebuild 881 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. PYTHON_REQ_USE='threads(+)'
  6. inherit python-any-r1 waf-utils
  7. DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
  8. HOMEPAGE="http://drobilla.net/software/serd/"
  9. SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
  10. LICENSE="ISC"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc x86"
  13. IUSE="doc static-libs test"
  14. RDEPEND=""
  15. DEPEND="${RDEPEND}
  16. ${PYTHON_DEPS}
  17. doc? ( app-doc/doxygen )"
  18. DOCS=( "AUTHORS" "NEWS" "README" )
  19. src_prepare() {
  20. sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
  21. }
  22. src_configure() {
  23. waf-utils_src_configure \
  24. --docdir=/usr/share/doc/${PF} \
  25. $(use test && echo "--test") \
  26. $(use doc && echo "--docs") \
  27. $(use static-libs && echo "--static")
  28. }
  29. src_test() {
  30. ./waf test || die
  31. }