uthash-1.9.9.ebuild 707 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-funcs
  5. DESCRIPTION="An easy-to-use hash implementation for C programmers"
  6. HOMEPAGE="http://troydhanson.github.io/uthash/index.html"
  7. SRC_URI="https://github.com/troydhanson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD-1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
  11. IUSE="test"
  12. DEPEND="sys-apps/sed
  13. test? ( dev-lang/perl )"
  14. RDEPEND=""
  15. src_test() {
  16. cd tests || die
  17. sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die
  18. emake CC="$(tc-getCC)"
  19. }
  20. src_install() {
  21. insinto /usr/include
  22. doins src/*.h
  23. dodoc doc/{ChangeLog,todo,userguide,ut*}.txt
  24. }