xmlrpc-c-1.39.11-r1.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # Upstream maintains 3 release channels: http://xmlrpc-c.sourceforge.net/release.html
  5. # 1. Only the "Super Stable" series is released as a tarball
  6. # 2. SVN tagging of releases seems spotty: http://svn.code.sf.net/p/xmlrpc-c/code/release_number/
  7. # Because of this, we are following the "Super Stable" release channel
  8. DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
  9. HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
  10. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  14. IUSE="abyss +cgi +curl +cxx +libxml2 threads test tools"
  15. REQUIRED_USE="test? ( abyss curl cxx ) tools? ( curl )"
  16. DEPEND="
  17. sys-libs/ncurses:0=
  18. sys-libs/readline:0=
  19. curl? ( net-misc/curl )
  20. libxml2? ( dev-libs/libxml2 )"
  21. RDEPEND="${DEPEND}"
  22. PATCHES=(
  23. "${FILESDIR}/${PN}-1.32.05-Wimplicit.patch"
  24. "${FILESDIR}/${P}-cplusplus.patch"
  25. )
  26. pkg_setup() {
  27. use curl || ewarn "Curl support disabled: No client library will be built"
  28. }
  29. src_prepare() {
  30. sed -i \
  31. -e "/CFLAGS_COMMON/s|-g -O3$||" \
  32. -e "/CXXFLAGS_COMMON/s|-g$||" \
  33. common.mk || die
  34. eapply ${PATCHES[@]}
  35. eapply_user
  36. }
  37. src_configure() {
  38. econf \
  39. --disable-wininet-client \
  40. --disable-libwww-client \
  41. --without-libwww-ssl \
  42. $(use_enable libxml2 libxml2-backend) \
  43. $(use_enable threads abyss-threads) \
  44. $(use_enable cgi cgi-server) \
  45. $(use_enable abyss abyss-server) \
  46. $(use_enable cxx cplusplus) \
  47. $(use_enable curl curl-client)
  48. }
  49. src_compile() {
  50. # Parallel builds are fixed in v 1.43.x or newer
  51. emake -j1
  52. use tools && emake -rC "${S}"/tools
  53. }
  54. src_install() {
  55. default
  56. use tools && emake DESTDIR="${D}" -rC "${S}"/tools install
  57. }