zookeeper-c-3.4.8.ebuild 695 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="C client interface to Zookeeper server"
  5. HOMEPAGE="https://zookeeper.apache.org/"
  6. SRC_URI="mirror://apache/zookeeper/zookeeper-${PV}/zookeeper-${PV}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE="doc static-libs test"
  11. RDEPEND=""
  12. DEPEND="${RDEPEND}
  13. doc? ( app-doc/doxygen )
  14. test? ( dev-util/cppunit )"
  15. S="${WORKDIR}/zookeeper-${PV}/src/c"
  16. src_configure() {
  17. econf \
  18. $(use_enable static-libs static) \
  19. $(use_with test cppunit)
  20. }
  21. src_compile() {
  22. emake
  23. use doc && emake doxygen-doc
  24. }
  25. src_install() {
  26. default
  27. use doc && dohtml docs/html/*
  28. }