camomile-0.8.5-r1.ebuild 888 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit findlib eutils
  5. DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
  6. HOMEPAGE="https://github.com/yoriyuki/Camomile/wiki"
  7. SRC_URI="https://github.com/yoriyuki/Camomile/releases/download/rel-${PV}/${P}.tar.bz2"
  8. LICENSE="LGPL-2"
  9. SLOT="0/${PV}"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE="debug +ocamlopt"
  12. RDEPEND="
  13. >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
  14. dev-ml/camlp4:=
  15. "
  16. DEPEND="${RDEPEND}"
  17. src_prepare() {
  18. has_version '>=dev-lang/ocaml-4.05_beta' && epatch "${FILESDIR}/ocaml405.patch"
  19. }
  20. src_configure() {
  21. econf $(use_enable debug)
  22. }
  23. src_compile() {
  24. emake -j1 byte unidata unimaps charmap_data locale_data
  25. if use ocamlopt; then
  26. emake -j1 opt
  27. fi
  28. }
  29. src_install() {
  30. dodir /usr/bin
  31. findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
  32. }