mongo-0.67.2.ebuild 498 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit oasis
  5. DESCRIPTION="An ocaml driver for mongodb"
  6. HOMEPAGE="http://massd.github.io/"
  7. SRC_URI="https://github.com/MassD/mongo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0/${PV}"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ml/bson:=
  14. dev-ml/lwt:=
  15. "
  16. DEPEND="${RDEPEND} dev-ml/oasis"
  17. src_prepare() {
  18. epatch "${FILESDIR}/noinstalltest.patch"
  19. oasis setup || die
  20. }