ocaml-gettext-0.3.7.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit findlib eutils autotools
  5. DESCRIPTION="Provides support for internationalization of OCaml program"
  6. HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
  7. SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="LGPL-2.1-with-linking-exception"
  9. SLOT="0/${PV}"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc test"
  12. RDEPEND=">=dev-lang/ocaml-3.12.1:=
  13. >=dev-ml/ocaml-fileutils-0.4.0:=
  14. >=dev-ml/camomile-0.8.3:=
  15. sys-devel/gettext
  16. dev-ml/camlp4:=
  17. "
  18. DEPEND="${RDEPEND}
  19. doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
  20. test? ( dev-ml/ounit )"
  21. src_prepare() {
  22. eautoreconf
  23. }
  24. src_configure() {
  25. econf \
  26. --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
  27. $(use_enable doc) \
  28. $(use_enable test)
  29. }
  30. src_compile() {
  31. emake -j1
  32. }
  33. src_install() {
  34. findlib_src_preinst
  35. emake -j1 DESTDIR="${D}" \
  36. BINDIR="${ED}/usr/bin" \
  37. PODIR="${ED}/usr/share/locale/" \
  38. DOCDIR="${ED}/usr/share/doc/${PF}" \
  39. MANDIR="${ED}/usr/share/man" \
  40. install
  41. dodoc CHANGELOG README THANKS TODO
  42. }