ppx_tools_versioned-5.0_beta1.ebuild 595 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit findlib
  5. MY_PV=${PV/_/}
  6. MY_P=${PN}-${MY_PV}
  7. DESCRIPTION="Tools for authors of ppx rewriters"
  8. HOMEPAGE="https://github.com/let-def/ppx_tools_versioned"
  9. SRC_URI="https://github.com/let-def/ppx_tools_versioned/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
  10. LICENSE="MIT"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64"
  13. IUSE=""
  14. DEPEND="
  15. dev-lang/ocaml:=
  16. dev-ml/ocaml-migrate-parsetree:=
  17. "
  18. RDEPEND="${DEPEND}"
  19. S="${WORKDIR}/${MY_P}"
  20. src_install() {
  21. findlib_src_install
  22. dodoc README.md
  23. }