controller_manager_msgs-0.11.1.ebuild 464 B

123456789101112131415161718192021
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-controls/ros_control"
  5. KEYWORDS="~amd64"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. CATKIN_HAS_MESSAGES=yes
  9. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
  10. inherit ros-catkin
  11. DESCRIPTION="The controller manager"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="dev-ros/rospy[${PYTHON_USEDEP}]"
  16. DEPEND="${RDEPEND}"