controller_manager_tests-9999.ebuild 593 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-controls/ros_control"
  5. KEYWORDS="~amd64"
  6. ROS_SUBDIR=${PN}
  7. PYTHON_COMPAT=( python2_7 )
  8. inherit ros-catkin
  9. DESCRIPTION="Tests for the controller manager"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. IUSE=""
  13. RDEPEND="
  14. dev-ros/controller_manager[${PYTHON_USEDEP}]
  15. dev-ros/controller_interface
  16. dev-ros/control_toolbox
  17. "
  18. DEPEND="${RDEPEND}
  19. test? (
  20. dev-ros/rostest[${PYTHON_USEDEP}]
  21. dev-python/nose[${PYTHON_USEDEP}]
  22. dev-ros/rosservice[${PYTHON_USEDEP}]
  23. )"