cpp_common-0.5.6.ebuild 418 B

1234567891011121314151617181920
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/roscpp_core"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="C++ code for doing things that are not necessarily ROS related"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-libs/console_bridge
  14. dev-libs/boost:=[threads]"
  15. DEPEND="${RDEPEND}"